选择道路的时候怎么犹豫都没有关系,但决定之后就一定要坚持到底! 每日签到 收藏本站
登陆 / 注册 搜索

USERCENTER


查看:11836   回复: 17

[# 易语言] 如何判断电脑系统是虚拟机还是物理机?(已修改)

[复制链接]
发新帖
跳转到指定楼层
楼主
清风徐来「出类拔萃」 发表于 2017-7-10 19:16:46 | 只看该作者 回帖奖励 |倒序浏览 |阅读模式

这个用户很懒,还没有填写自我介绍呢~

本帖最后由 清风徐来 于 2017-7-26 14:57 编辑

工具:二手主机一台,自制烂大街的鼠标一只,搓衣板牌键盘,易语言。     
主要原理:利用易语言,取出Dos的结果,再来判断“Virutal”特殊关键字字符,若寻找到关键字字符“Virutal”的话就是虚拟机,反之没有关键字字符“Virutal”就是物理机。



#f464:

[Dos命令:Systeminfo]


#f472:
老规矩:回复下载!
游客,如果您要查看本帖隐藏内容请回复

至于其他的,就自己看源码咯!

如果您觉得本帖对您有帮助,记得给我加分哦,加分不扣自己的分!


                                      我一定要把币补回来!
下面是取Dos代码升级版:
  1. .版本 2

  2. .子程序 Take_the_Dos_Execution_Results, 文本型, , 这个子程序返回的,是Dos 的回执结果,Dos命令:Systeminfo | findstr /i "System Model"
  3. .局部变量 SECURITY_ATTRIBUTES, SECURITY_ATTRIBUTES
  4. .局部变量 STARTUPINFO, STARTUPINFO
  5. .局部变量 PROCESS_INFORMATION, PROCESS_INFORMATION
  6. .局部变量 hWrite, 整数型
  7. .局部变量 hRead, 整数型
  8. .局部变量 txt, 字节集
  9. .局部变量 len, 整数型
  10. .局部变量 EXIT, 整数型
  11. .局部变量 retext, 文本型

  12. SECURITY_ATTRIBUTES.nLength = 12
  13. SECURITY_ATTRIBUTES.lpSecurityDescriptor = 0
  14. SECURITY_ATTRIBUTES.bInheritHandle = 1
  15. CreatePipe (hRead, hWrite, SECURITY_ATTRIBUTES, 0)
  16. STARTUPINFO.cb = 68
  17. STARTUPINFO.dwFlags = 位或 (#STARTF_USESHOWWINDOW, #STARTF_USESTDHANDLES)
  18. STARTUPINFO.wShowWindow = #SW_HIDE
  19. STARTUPINFO.hStdOutput = hWrite
  20. STARTUPINFO.hStdError = hWrite
  21. .如果 (取操作系统类别 () ≤ 2)
  22.     CreateProcess (0, “command.com /c Systeminfo”, 0, 0, 真, 0, 0, 0, STARTUPINFO, PROCESS_INFORMATION)  ' 代码
  23. .否则
  24.     CreateProcess (0, “cmd.exe /c Systeminfo”, 0, 0, 真, 0, 0, 0, STARTUPINFO, PROCESS_INFORMATION)  ' 代码
  25. .如果结束

  26. CloseHandle (hWrite)
  27. .判断循环首 (len ≠ -1)
  28.     PeekNamedPipe (hRead, 0, 0, 0, len, 0)
  29.     .如果 (len ≠ 0)
  30.         txt = 取空白字节集 (1024)
  31.         ReadFile (hRead, txt, 1023, len, 0)
  32.         retext = retext + 取字节集数据 (txt, #文本型)
  33.     .否则
  34.         GetExitCodeProcess (PROCESS_INFORMATION.hProcess, EXIT)
  35.         .如果真 (EXIT ≠ #STILL_ACTIVE)
  36.             CloseHandle (hRead)
  37.             跳出循环 ()
  38.         .如果真结束

  39.     .如果结束
  40.     处理事件 ()
  41. .判断循环尾 ()
  42. 返回 (retext)
复制代码

评分

参与人数 2成长值 +4 金币 +6 收起 理由
空谷幽兰 + 1 + 1 ————————————————————.
小执念 + 3 + 5 热心回复!

查看全部评分

推荐
空谷幽兰仗剑天涯 发表于 2017-7-11 16:42:27 | 只看该作者
易语言写的东西就是容易误报#j354:
  收起(1)
  • 清风徐来:


    你的用户组好亮,啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊,我看不见,什么都看不见!!!!!!!!
    2017-07-11 20:29 
推荐
楼主| 清风徐来「出类拔萃」 发表于 2017-7-11 10:36:47
小执念 发表于 2017-7-10 23:34
你这个不管在物理机还是虚拟机上,都显示同一个结果:

捣鼓的一下,这才发现,那个子程序返回的值为空,后来我修改了,不过还是不行,我百度了一下,发现虚拟机都有去虚化的,直接检测系统信息基本是无法检测出的。。。我打算用你那个方法来测,再做一次。

评分

参与人数 1成长值 +1 金币 +1 收起 理由
空谷幽兰 + 1 + 1 热心回复!

查看全部评分

推荐
小执念古黑浩劫论坛大牛 发表于 2017-7-10 23:34:49 | 只看该作者
      你这个不管在物理机还是虚拟机上,都显示同一个结果:

 QQ截图20170710233251.jpg 如何判断电脑系统是虚拟机还是物理机?(已修改)


 QQ截图20170710233218.jpg 如何判断电脑系统是虚拟机还是物理机?(已修改)


      还是我大Linux好,直接命令“dmidecode -s system-product-name


 QQ截图20170710232537.jpg 如何判断电脑系统是虚拟机还是物理机?(已修改)

  收起(1)
  • 清风徐来:


    捣鼓的一下,这才发现,那个子程序返回的值为空,后来我修改了,不过还是不行,我百度了一下,发现虚拟机都有去虚化的,直接检测系统信息基本是无法检测出的。。。我打算用你那个方法来测,再做一次。

    2017-07-11 10:36 
小执念古黑浩劫论坛大牛 发表于 2017-7-10 23:47:54 | 只看该作者
附上虚拟机信息  QQ截图20170710234634.jpg 如何判断电脑系统是虚拟机还是物理机?(已修改)

评分

参与人数 1成长值 +1 金币 +1 收起 理由
清风徐来 + 1 + 1 很给力!

查看全部评分

空谷幽兰仗剑天涯 发表于 2017-7-11 16:41:24 | 只看该作者
我就不回复
7#
楼主| 清风徐来「出类拔萃」 发表于 2017-7-11 20:29:35
空谷幽兰 发表于 2017-7-11 16:42
易语言写的东西就是容易误报

你的用户组好亮,啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊,我看不见,什么都看不见!!!!!!!!

评分

参与人数 1成长值 +1 金币 +1 收起 理由
空谷幽兰 + 1 + 1 你最丑

查看全部评分

8#
小执念古黑浩劫论坛大牛 发表于 2017-7-26 22:28:23 | 只看该作者
你自己测试好了,放截图不就行了
9#
soarcloud「出类拔萃」 发表于 2017-8-11 09:05:16 | 只看该作者
用管道方式将Systeminfo命令的结果导出,再在结果中查询理论上应该可以绕过虚拟机的去虚拟化

评分

参与人数 1成长值 +1 金币 +1 收起 理由
清风徐来 + 1 + 1 想过这个问题~

查看全部评分

10#
流星☆坠落「出类拔萃」 发表于 2018-1-21 20:12:17 来自手机 | 只看该作者
楼主的帖子实在是写得太好了。文笔流畅,修辞得体,深得魏晋诸朝遗风,更将唐风宋骨发扬得入木三分,能在有生之年看见楼主的这个帖子。实在是我三生之幸啊。看完楼主的这个帖子之后,我竟产生出一种无以名之的悲痛感——啊,这么好的帖子,如果将来我再也看不到了,那我该怎么办?那我该怎么办?直到我毫不犹豫地把楼主的这个帖子收藏了,我内心的那种激动才逐渐平静下来。可是我立刻想到,这么好的帖子,倘若别人看不到,那么不是浪费楼主的心血吗?经过痛苦的思想斗争,我终于下定决心,牺牲小我,奉献大我。我要拿出这帖子奉献给人赏阅,我要把这个帖子一直往上顶,往上顶!顶到所有人都看到为止!
11#
眼泪早已泛滥「出类拔萃」 发表于 2018-1-21 23:45:58 来自手机 | 只看该作者
告诉大家一个信息,论坛惊天bug,回复:我是傻B。会自动变成:楼主傻B。到现在还没有修复,不信可以试试!
12#
有正事「初入古黑」 发表于 2018-4-8 08:26:25 | 只看该作者
下载
13#
wps2004「初入古黑」 发表于 2018-11-2 10:03:04 | 只看该作者
支持一个!!!
您需要登录后才可以回帖 登录 | 立即注册  

本版积分规则

关于我们|小黑屋|手机版|Archiver|古黑论

GMT+8, 2019-8-26 11:33 , Processed in 0.046485 second(s), 48 queries , Gzip On, Redis On.

© 2015-2019 GuHei.Net

Powered by Discuz! X3.4

快速回复 返回列表