在你最冷的时候,有人不顾自己寒冷抱着你,这就是幸福。 每日签到 收藏本站
登陆 / 注册 搜索

USERCENTER


查看:7169   回复: 3

[# 易语言] 判断是否是易语言文件

[复制链接]
发新帖
跳转到指定楼层
楼主
清风徐来「出类拔萃」 发表于 2017-7-3 18:32:57 | 只看该作者 回帖奖励 |倒序浏览 |阅读模式

这个用户很懒,还没有填写自我介绍呢~

本帖最后由 清风徐来 于 2017-7-3 18:38 编辑

易语言文件包括:*.e(源码) *.ec(模块)
代码很简单
下面是代码:(子程序)
  1. .版本 2
  2. .子程序 文件是否为易文件, 逻辑型
  3. .参数 欲测试文件名, 文本型
  4. .局部变量 数据_字节集, 字节集
  5. 数据_字节集 = 读入文件 (欲测试文件名)
  6. ' 调试输出 (数据_字节集)
  7. .如果真 (删全部空 (到文本 (数据_字节集)) = “”)
  8.     返回 (假)
  9. .如果真结束
  10. .如果真 (到文本 (取字节集中间 (数据_字节集, 1, 8)) ≠ “CNWTEPRG”)
  11.     ' 调试输出 (到文本 (取字节集中间 (数据_字节集, 1, 8)))
  12.     返回 (假)
  13. .如果真结束
  14. ' 调试输出 (到文本 (取字节集中间 (数据_字节集, 1, 8)))
  15. 返回 (真)
复制代码
我不知道网上有没有类似的源码,但是我可以肯定,这是我自己写的哈!
(这个程序我参考了下曙光前辈的代码,但是觉得有点复杂,所以我在这里再写个简单的)
易语言由“CNWTEPRG”魔数+一些未知数据构成,此程序就是利用此来判断的!
刚刚忘了附件... 判断是否为易程序.rar (1.37 KB, 下载次数: 2)

评分

参与人数 1成长值 +1 金币 +1 收起 理由
小执念 + 1 + 1 热心回复!

查看全部评分

小执念古黑浩劫论坛大牛 发表于 2017-7-3 19:42:10 | 只看该作者
不明觉厉#j346:
雾月「出类拔萃」 发表于 2017-9-3 07:28:42 来自手机 | 只看该作者
OMG!介是啥东东!!!
初晓微芒「出类拔萃」 发表于 2018-1-21 09:22:07 来自手机 | 只看该作者
本来我已决定不会再回任何帖子了,当我览遍无数烂贴、痛恨生不逢时,行走在思想的戈壁荒原、穷山恶水之间,感到前途渺茫、万念俱灰之际,却突然看到这样一篇绝世好贴!我真是热泪纵横、感激涕零告诉自己如此经典之贴是一定要回的!这正是千百年来版友翘首以待的好贴啊!
凉冬空巷龙战于野 发表于 2018-1-21 23:19:15 来自手机 | 只看该作者
  在逐字逐句地看完这个帖子以后,我的心久久不能平静,震撼啊!为什么会有如此好的帖子?!我纵横网络bbs多年,自以为再也不会有任何帖子能打动我,没想到今天看到了如此精妙绝伦的这样一篇帖子。
您需要登录后才可以回帖 登录 | 立即注册  

本版积分规则

关于我们|小黑屋|手机版|Archiver|古黑论

GMT+8, 2019-8-26 13:58 , Processed in 0.046677 second(s), 34 queries , Gzip On, Redis On.

© 2015-2019 GuHei.Net

Powered by Discuz! X3.4

快速回复 返回列表